Firefox scripts

[Note: I've just learned that the recent Firefox 1.5 upgrade makes this script no longer function. I'm not sure whether there is still a troll problem on the forums; if so, please private message me on the SciFi forum and I will look into upgrading the script.]


Upgrading? Go to Tools/Manage User Scripts and manually uninstall the previous version before installing this one. Sorry, this is a limitation of Greasemonkey.

Installing for the first time? You need Greasemonkey. Then restart Firefox and click here. Under Tools, there will be a new menu item to "Install User Script". Accept the default configuration and install.

Hesitant? Good idea, since you can't trust some guy with a script. Feel free to ask around for trustworthy confirmation, if you're not experienced reading code. Or if you're hesitant to upgrade because you don't want to lose your old killfile, don't worry -- it will be preserved between upgrades.